Supported frameworks and platforms

Component: NServiceBus
NuGet Package: NServiceBus (7.4 - 7.5)

Supported frameworks can be used for production workloads with technical support available from Particular Software.

FrameworkVersionPlatformSupport
.NET Framework4.5.2 or later1WindowsSupported
.NET Core3.1 (LTS)Windows / LinuxSupported until Dec. 3, 2022
.NET5.0Windows / LinuxSupported until May 8, 2022
.NET6.0 (LTS)Windows / LinuxSupported until Nov. 8, 2024

1 Some packages may require a later version of the .NET Framework.

macOS is supported for development purposes but not for production workloads.

Related Articles


Last modified