.NET Framework requirements

NServiceBus version 8.x

NServiceBus version 8.x is a pre-release version and is subject to change prior to the final release.

Requires .NET Core 3.1 (or higher) or .NET Framework Version 4.7.2 (or higher)

NServiceBus version 7.x

Requires .NET Core 2.0 (or higher) or .NET Framework Version 4.5.2 (or higher)

NServiceBus version 6.x

Requires .NET Framework Version 4.5.2 (or higher)

NServiceBus version 5.x

Requires .NET Framework Version 4.5 (or higher)

NServiceBus versions 3.x and 4.x

Requires .NET Framework Version 4.0 (or higher)


NServiceBus targets a specific version of the .NET Framework but that does not mean user code must be targeting the same version. This only indicates the minimum required .NET Framework. The actual framework used at runtime is determined by the application.

See Targeting and running .NET Framework apps for version 4.5 and later and Version compatibility in the .NET Framework for more information.

Related Articles

Last modified